multiplyXYZWToFloat64Array Method

Transform the homogeneous point. Return as new Float64Array with size 4, or in the pre-allocated result of sufficient size.

  • If p = (x,y,z) then this method computes Tp = M*p + o*w and returns the Float64Array formed by Tp in the first 3 numbers of the array and w as the fourth.
  • Logically, this is multiplication by the 4x4 matrix formed from the 3x4 instance augmented with fourth row 0001.

multiplyXYZWToFloat64Array(x: number, y: number, z: number, w: number, result?: Float64Array): Float64Array

Parameter Type Description
x number  
y number  
z number  
w number  
result Float64Array  

Returns - Float64Array

Defined in

Last Updated: 16 April, 2024