setFromJSON Method

Set this Transform instance from flexible inputs:

  • Any object (such as another Transform or TransformProps) that has origin and matrix members accepted by Point3d.setFromJSON and Matrix3d.setFromJSON
  • An array of 3 number arrays, each with 4 entries which are rows in a 3x4 matrix.
  • An array of 12 numbers, each block of 4 entries as a row 3x4 matrix.
  • If no input is provided, the identity Transform is returned.

setFromJSON(json?: TransformProps | Transform): void

Parameter Type Description
json TransformProps | Transform  

Returns - void

Defined in

Last Updated: 16 April, 2024