interpolate Method

Return a vector computed at fractional position between this vector and vectorB

interpolate(fraction: number, vectorB: Vector2d, result?: Vector2d): Vector2d

Parameter Type Description
fraction number fractional position. 0 is at this. 1 is at vectorB.
True fractions are "between", negatives are "before this", beyond 1 is "beyond vectorB".
vectorB Vector2d second vector
result Vector2d optional preallocated result.

Returns - Vector2d

Defined in

Last Updated: 13 May, 2024