createMiteredSweepSections MethodStatic

Sweep the initialSection along each segment of the centerLine until it hits the bisector plane at the next vertex.

  • The caller should place the initialSection on a plane perpendicular to the first edge.
    • This plane is commonly (but not necessarily) through the start point itself.
    • If the geometry is not "on a perpendicular plane", the output geometry will still be flattened onto the various planes.
  • In the "open path" case (i.e when wrapIfPhysicallyClosed is false or the path does not have matched first and last points) the first/last output plane will be at the start/end of the first/last edge and on a perpendicular plane.
  • In the "closed path" case, the output plane for the first and last point is the bisector of the start and end planes from the "open path" case, and the first/last section geometry may be different from initialSection.
  • The centerline path does NOT have to be planar, however twisting effects effects will appear in the various bisector planes.

createMiteredSweepSections(centerline: IndexedXYZCollection | Point3d[], initialSection: AnyCurve, options: MiteredSweepOptions): undefined | SectionSequenceWithPlanes

@returns array of sections, starting with initialSection projected along the first edge to the first plane.

Parameter Type Description
centerline IndexedXYZCollection | Point3d[] sweep path, e.g., as stroked from a smooth centerline curve
initialSection AnyCurve profile curve to be swept. As noted above, this should be on a plane perpendicular to the first segment of the centerline.
options MiteredSweepOptions options for computation and output

Returns - undefined | SectionSequenceWithPlanes

array of sections, starting with initialSection projected along the first edge to the first plane.

Defined in

Last Updated: 13 May, 2024