constructPolygonWireXYOffset MethodStatic

Construct a wire that is offset from the given polyline or polygon.

  • This is a simple wire offset, not an area offset.
  • Since z-coordinates are ignored, for best results the input points should lie in (a plane parallel to) the xy-plane.
  • The construction algorithm attempts to eliminate some self-intersections within the offsets, but does not guarantee a simple area offset.

constructPolygonWireXYOffset(points: Point3d[], wrap: boolean, offsetDistanceOrOptions: number | JointOptions): undefined | CurveChain

Parameter Type Description
points Point3d[] a single loop or path
wrap boolean true to include wraparound
offsetDistanceOrOptions number | JointOptions offset distance (positive to left of curve, negative to right) or JointOptions
object.

Returns - undefined | CurveChain

Defined in

Last Updated: 16 April, 2024