WebFontIconProps Interface

Properties for the WebFontIcon React component

Extends

Properties

Name Type Description
iconClassName undefined | string Class name of icon used for custom font-family icons  
iconName string Bentley Web Font icon name  
iconSize "small" | "medium" | "large" | "x-large" | "x-small" Size of the icon  
onClick undefined | MouseEventHandler<HTMLSpanElement> Click event handler  
title undefined | string Text that will be shown when hovered on the icon.  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 21 March, 2024