Inputs
Components for working with input controls, such as Input, IconInput and NumberInput.
Classes
Name | Description | |
---|---|---|
InputLabel | Text input wrapper that provides additional styling and labeling |
Enumerations
Name | Description | |
---|---|---|
InputStatus | Enum for Input status |
Global Functions
Name | Description | |
---|---|---|
IconInput | Input component with icon to the left of the input field | |
NumberInput | Input component for numbers with up and down buttons to increment and decrement the value. |
Interfaces
Name | Description | |
---|---|---|
IconInputProps | Properties for the IconInput component | |
InputLabelProps | Properties for InputLabel components | |
LabeledComponentProps | Properties for labeled components | |
Properties for components with messages | ||
NumberInputProps | Properties for the NumberInput component |
Type Aliases
Name | Description | |
---|---|---|
StepFunctionProp | Step function prototype for NumberInput component |
Last Updated: 18 August, 2023