merge Method

Overloads
merge(differences)  
merge(targetSchema, sourceSchema)  

merge(differences)

Merges the schema differences into the target schema context.

merge(differences: ): Promise<Schema>

Parameter Type Description
differences The changes that shall be applied to the target schema.

Returns - Promise<Schema>



merge(targetSchema, sourceSchema)

Copy the SchemaItems of the source schemas to the target schema.

merge(targetSchema: Schema, sourceSchema: Schema): Promise<Schema>

@returns The merged target schema.

Parameter Type Description
targetSchema Schema The schema the SchemaItems gets merged to.
sourceSchema Schema The schema the SchemaItems gets copied from.

Returns - Promise<Schema>

The merged target schema.


Defined in

Last Updated: 13 May, 2024