getSchemaItemSync Method

Gets the schema item from the specified schema if it exists in this SchemaContext. Will skip a partially loaded schema and return undefined if the item belongs to that schema. Use the async method to await partially loaded schemas.

getSchemaItemSync<T extends SchemaItem<T>>(schemaItemKey: SchemaItemKey): undefined | T

@returns The requested schema item

Parameter Type Description
schemaItemKey SchemaItemKey The SchemaItemKey identifying the item to return. SchemaMatchType.Latest is used to match the schema.

Returns - undefined | T

The requested schema item

Defined in

Last Updated: 16 April, 2024