ITwinElectronApi Interface

These methods are stored on window.itwinjs

Properties

Name Type Description
addListener (channel: string, listener: ElectronListener) => void    
invoke (channel: string, ...data: any[]) => Promise<any>    
once (channel: string, listener: (event: any, ...args: any[]) => void) => void    
removeListener (channel: string, listener: ElectronListener) => void    
send (channel: string, ...data: any[]) => void    

Defined in

Last Updated: 21 March, 2024