imodel-transformer

Classes

Name Description
ChangedInstanceIds Class for discovering modified elements between 2 versions of an iModel.
ChangedInstanceOps Class for holding change information.
IModelCloneContext The context for transforming a source Element to a target Element and remapping internal identifiers to the target iModel.
IModelExporter Base class for exporting data from an iModel.
IModelExportHandler Handles the events generated by IModelExporter.
IModelImporter Base class for importing data into an iModel.
IModelTransformer Base class used to transform a source iModel into a different target iModel.
PendingReferenceMap a map that supports using PendingReferences objects as structural keys,
TemplateModelCloner IModelTransformer that clones the contents of a template model.

Enumerations

Name Description
TransformerLoggerCategory Logger categories used by this package

Interfaces

Name Description
ExportSchemaResult The (optional) result of IModelExportHandler.onExportSchema
IModelImportOptions Options provided to the IModelImporter constructor.
IModelTransformOptions Options provided to the IModelTransformer constructor.
InitFromExternalSourceAspectsArgs Arguments you can pass to IModelTransformer.initExternalSourceAspects
OptimizeGeometryOptions Options provided to IModelImporter.optimizeGeometry specifying post-processing optimizations to be applied to the iModel's geometry.

Namespaces

Name Description
PendingReference

Last Updated: 26 April, 2023