onDeleteElement MethodProtected

Delete the specified Element (and all its children) from the target iModel. Will delete special elements like definition elements and subjects.

onDeleteElement(elementId: string): void

@note A subclass may override this method to customize delete behavior but should call super.onDeleteElement.

Parameter Type Description
elementId string  

Returns - void

Defined in

Last Updated: 13 May, 2024