processModelContents Method

Cause the model contents to be exported from the source iModel and imported into the target iModel.

processModelContents(sourceModelId: string, targetModelId: string, elementClassFullName: string = Element.classFullName): Promise<void>

@note This method is called from IModelTransformer.processChanges and IModelTransformer.processAll, so it only needs to be called directly when processing a subset of an iModel.

Parameter Type Description
sourceModelId string Import the contents of this model from the source IModelDb.
targetModelId string Import into this model in the target IModelDb. The target model must exist prior to this call.
elementClassFullName string Optional classFullName of an element subclass to limit import query against the source model.

Returns - Promise<void>

Defined in

Last Updated: 13 December, 2023