constructor Method

Creates an instance of Item.

Item(primaryKeys: InstanceKey[], label: string | LabelDefinition, imageId: string, classInfo: undefined | ClassInfo, values: ValuesDictionary<Value>, displayValues: ValuesDictionary<DisplayValue>, mergedFieldNames: string[], extendedData?: { T }): Item

Parameter Type Description
primaryKeys InstanceKey[] Keys of instances whose data is contained in this item
label string | LabelDefinition Display label of the item
imageId string ID of the image associated with this item
classInfo undefined | ClassInfo For cases when item consists only of same class instances, information about the ECClass
values ValuesDictionary<Value> Raw values dictionary
displayValues ValuesDictionary<DisplayValue> Display values dictionary
mergedFieldNames string[] List of field names whose values are merged (see Merging values)
extendedData { T } Extended data injected into this content item

Returns - Item

Defined in

Last Updated: 16 April, 2024