InstanceFilterDefinition Interface

Definition of an instance filter that can be used to filter content or hierarchy levels.

Example:

{
  selectClassName: "MySchema:MyClass",
  expression: "this.MyProperty = 1 AND other.OtherProperty = 2",
  relatedInstances: [{
    pathFromSelectToPropertyClass: [{
        sourceClassName: "MySchema:MyClass",
        relationshipName: "MySchema:RelationshipFromMyToOtherClass",
        isForwardRelationship: true,
        targetClassName: "MySchema:OtherClass",
    }],
    alias: "other",
  }],
}

Properties

Name Type Description
expression string ECExpression for filtering the select instances.  
relatedInstances undefined | InstanceFilterRelatedInstanceDefinition[] Specifies relationship paths pointing to related instances used in the InstanceFilterDefinition.expression attribute.  
selectClassName string Select class filter used to select only instances of specific class.  

Defined in

Last Updated: 15 March, 2024