MultiElementPropertiesRequestOptions<TIModel, TParsedContent> Interface

Request type for multiple elements properties requests.

Extends

Properties

Name Type Description
batchSize undefined | number The properties of multiple elements are going to be retrieved and returned in batches.  
contentParser undefined | (descriptor: Descriptor, item: Item) => TParsedContent    
elementClasses undefined | string[] Classes of the elements to get properties for.  

Inherited properties

Name Type Inherited from Description
imodel TIModel RequestOptions<TIModel> iModel to request data from
locale undefined | string RequestOptions<TIModel> Optional locale to use when formatting / localizing data
unitSystem undefined | UnitSystemKey RequestOptions<TIModel> Unit system to use when formatting property values with units.

Defined in

Last Updated: 15 March, 2024