ServiceAuthorizationClientConfiguration Interface

Configuration of clients for service or service applications.

@see ServiceAuthorizationClient for notes on registering an application

Properties

Name Type Description
authority Readonly undefined | string The URL of the OIDC/OAuth2 provider.  
clientId Readonly string Client application's identifier as registered with the Bentley IMS OIDC/OAuth2 provider.  
clientSecret Readonly string Client application's secret key as registered with the Bentley IMS OIDC/OAuth2 provider.  
scope Readonly string List of space separated scopes to request access to various resources.  

Defined in

Last Updated: 21 March, 2024