GraphicsDriverBugs Interface

Known bugs associated with specific graphics drivers for which iTwin.js can apply workarounds to produce correct visualization. An instance of this object will exist on the WebGLRenderCompatibilityInfo object returned by queryRenderCompatibility.

@see WebGLRenderCompatibilityInfo

Properties

Name Type Description
fragDepthDoesNotDisableEarlyZ undefined | "true" If true, the graphics driver inappropriately applies the "early Z" optimization when a fragment shader writes to the depth buffer.  
msaaWillHang undefined | "true" If true, the graphics driver will hang when applying MSAA to a viewport.  

Defined in

Last Updated: 16 April, 2024