ConfigurableBase Class

The base class for all ConfigurableUi elements

Extended by

Implements

Methods

Name Description
constructor(info: ConfigurableCreateInfo, options: any): ConfigurableBase    

Properties

Name Type Description
_appDataOptions Protected any    
applicationData Accessor ReadOnly any allow options set via appData to be seen by API calls  
classId Accessor ReadOnly string Gets the class Id of configurable element  
name Accessor ReadOnly string Get internal name of configurable element.  

Defined in

Last Updated: 05 April, 2024