ToolItemDef Class

An Item that starts the execution of a Tool.

Extends

Methods

Name Description
constructor(toolItemProps: ToolItemProps, onItemExecuted?: OnItemExecutedFunc): ToolItemDef    
getItemDefForTool(tool: undefined, icon?: string, ...args: any[]): ToolItemDef Static Create a ToolItemDef that will run a registered tool.  

Inherited methods

Name Inherited from Description
execute(): void ActionButtonItemDef Called when the action button is invoked by a click or touch
getDimension(orientation: Orientation): number ActionButtonItemDef Determines the dimension in a given orientation
handleSizeKnown(size: SizeProps): void ActionButtonItemDef Called when the size of the action button is initialized and the size is known
setDescription(v: string | StringGetter | ConditionalStringValue): void ActionButtonItemDef Set the description.
setLabel(v: string | StringGetter | ConditionalStringValue): void ActionButtonItemDef Set the label.
setTooltip(v: string | StringGetter | ConditionalStringValue): void ActionButtonItemDef Set the tooltip.
initializeDef(me: ItemDefBase, itemProps: ItemProps): void Static ActionButtonItemDef  

Properties

Name Type Description
id Accessor ReadOnly string    
toolId string    

Inherited properties

Name Type Inherited from Description
_commandHandler Protected undefined | CommandHandler ActionButtonItemDef Command Handler for the action button
applicationData undefined | any ActionButtonItemDef  
badgeType undefined | BadgeType ActionButtonItemDef  
defaultButtonSize Static number ActionButtonItemDef The default button size for all action buttons
description Accessor ReadOnly string ActionButtonItemDef Get the description string
iconElement undefined | ReactNode ActionButtonItemDef  
iconSpec undefined | IconSpec ActionButtonItemDef  
isActive Accessor boolean ActionButtonItemDef  
isDisabled boolean | ConditionalBooleanValue ActionButtonItemDef  
isHidden boolean | ConditionalBooleanValue ActionButtonItemDef  
isPressed boolean ActionButtonItemDef  
label Accessor ReadOnly string ActionButtonItemDef Get the label string
parameters undefined | any ActionButtonItemDef Parameters passed to the Command Handler
rawLabel Accessor ReadOnly string | StringGetter | ConditionalStringValue ActionButtonItemDef Get the label string
size undefined | SizeProps ActionButtonItemDef Size of the action button, as set by handleSizeKnown
tooltip Accessor ReadOnly string ActionButtonItemDef Get the tooltip string
trayId Accessor ReadOnly undefined ActionButtonItemDef  

Defined in

Last Updated: 05 April, 2024