AppNotificationManager Class

Subclass of NotificationManager in @itwin/core-frontend to be used to initialize IModelApp.

This implementation uses themed react components to display alerts, messages, prompts and tooltips.

await IModelApp.startup({
  notifications: new AppNotificationManager()
});

Extends

Methods

Name Description
constructor(): AppNotificationManager    
_showToolTip(el: HTMLElement, message: string | HTMLElement, pt?: Readonly<WritableXAndY>, options?: ToolTipOptions): void Protected Show a ToolTip window.  
clearToolTip(): void Clear the ToolTip if it is currently open.  
closeInputFieldMessage(): void Hide a InputField message.  
closePointerMessage(): void Hides the Pointer message.  
endActivityMessage(reason: ActivityMessageEndReason): boolean End an activity message.  
openMessageBox(mbType: MessageBoxType, message: string | HTMLElement, icon: MessageBoxIconType): Promise<MessageBoxValue> Output a MessageBox and wait for response from the user.  
outputActivityMessage(messageText: string | HTMLElement, percentComplete: number): boolean Output an activity message to the user.  
outputMessage(message: NotifyMessageDetails): void Output a message and/or alert to the user.  
outputPrompt(prompt: string): void Output a prompt to the user.  
outputPromptByKey(key: string): void Output a prompt, given an i18n key.  
setToolAssistance(instructions: undefined | ToolAssistanceInstructions): void Setup tool assistance instructions for a tool.  
setupActivityMessage(details: ActivityMessageDetails): boolean Set up for activity messages.  
updatePointerMessage(displayPoint: Readonly<WritableXAndY>, relativePosition: RelativePosition): void Update message position created with Pointer.  

Properties

Name Type Description
isToolTipOpen Accessor ReadOnly boolean Return true if the tooltip is currently open.  
isToolTipSupported Accessor ReadOnly boolean Return true if _showTooltip has an implementation and will display a tooltip.  

Defined in

Last Updated: 05 April, 2024