StateManager Class

Centralized state management class using Redux actions, reducers and store. This class monitors the ReducerRegistry and will automatically update the store when a new reducer is registered. This allows the store to be incrementally constructed as modules and/or extensions are loaded.

Methods

Name Description
constructor(defaultReducers?: NameToReducerMap): StateManager StateManager construct.  
isInitialized(suppressErrorLog: boolean = false): boolean Static Method to test if the StateManager has been initialized.  

Properties

Name Type Description
state Accessor StaticReadOnly any Return the current state from the Redux store.  
store Accessor StaticReadOnly Store<any, AnyAction> Return the current Redux store.  

Defined in

Last Updated: 05 April, 2024