ToolbarProps Interface

Properties of Toolbar component.

Extends

Properties

Name Type Description
enableOverflow boolean | OverflowToolbarOptions Describes if items that do not fit available space should move to an expandable panel.  
expandsTo undefined | Direction Describes to which direction the popup panels are expanded, also defines the orientation of the toolbar (Top/Bottom will create an horizontal toolbar, Left/Right will create a vertical toolbar).  
items ToolbarItem[] Definitions for items of the toolbar.  
onItemExecuted undefined | OnItemExecutedFunc Optional function to call on any item execution  
onKeyDown undefined | (e: KeyboardEvent<Element>) => void    
panelAlignment undefined | ToolbarPanelAlignment Describes how expanded panels are aligned.  
toolbarOpacitySetting undefined | ToolbarOpacitySetting Determines whether to use mouse proximity to alter the opacity of the toolbar  
useDragInteraction undefined | boolean Use Drag Interaction to open popups with nest action buttons  

Inherited properties

Name Type Inherited from Description
children undefined | undefined NoChildrenProps  
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 05 April, 2024