Toolbar

Classes used to construct a Toolbar

Classes

Name Description  
ToolbarHelper Helper functions for defining an ToolbarComposer.  

Enumerations

Name Description  
ToolbarOrientation Used to specify the orientation of the toolbar.  
ToolbarUsage Used to specify the usage of the toolbar which determine the toolbar position.  

Global Functions

Name Description  
isToolbarActionItem ToolbarActionItem type guard.  
isToolbarCustomItem ToolbarCustomItem type guard.  
isToolbarGroupItem ToolbarGroupItem type guard.  
Toolbar Component that displays toolbar items.  
ToolbarComposer Toolbar that is populated and maintained by item managers.  
ToolbarWithOverflow Component that displays toolbar items.  
useDefaultToolbarItems Hook that returns items from ToolbarItemsManager.  
useUiItemsProviderToolbarItems Hook that returns items from ToolbarItemsManager.  

Interfaces

Name Description  
CommonToolbarItem Describes the data needed to insert a UI items into an existing set of UI items.  
ExtensibleToolbarProps Properties for the ToolbarComposer React components  
ToolbarActionItem Describes the data needed to insert an action button into a toolbar.  
ToolbarCustomItem Describes the data needed to insert a custom button into a toolbar.  
ToolbarGroupItem Describes the data needed to insert a group button into a toolbar.  
ToolbarProps Properties of Toolbar component.  
ToolbarWithOverflowProps Component that displays toolbar items.  

Namespaces

Name Description  
ToolbarItemUtilities Helper class to create toolbar items.  

Type Aliases

Name Description  
ToolbarItem Any Button Type that can be inserted into a toolbar.  

Last Updated: 19 May, 2023