provideToolbarItems Method

Provides toolbar items.

provideToolbarItems(stageId: string, stageUsage: string, toolbarUsage: ToolbarUsage, toolbarOrientation: ToolbarOrientation, stageAppData?: any): ToolbarItem[]

@note Use UiItemsProvider.getToolbarItems instead. To map item to location previously specified by arguments use ToolbarItem.layouts.

Parameter Type Description
stageId string  
stageUsage string  
toolbarUsage ToolbarUsage  
toolbarOrientation ToolbarOrientation  
stageAppData any  

Returns - ToolbarItem[]

Defined in

Last Updated: 05 April, 2024