showMenuButton MethodStatic

Show a menu button at a particular location. A menu button opens a context menu.

showMenuButton(id: string, menuItemsProps: CursorMenuItemProps[], location: Readonly<WritableXAndY>, anchorElement?: HTMLElement): boolean

@returns true if the menu was displayed, false if the menu could not be displayed.

Parameter Type Description
id string Id of the menu button. Multiple menu buttons may be displayed.
menuItemsProps CursorMenuItemProps[] Properties of the menu items to display.
location Readonly<WritableXAndY> Location of the context menu, relative to the origin of anchorElement or the window.
anchorElement HTMLElement The HTMLElement that anchors the context menu. If undefined, the location is relative to the overall window.

Returns - boolean

true if the menu was displayed, false if the menu could not be displayed.

Defined in

Last Updated: 05 April, 2024