UiFramework Class

Main entry point to configure and interact with the features provided by the AppUi-react package.

Methods

Name Description
constructor(): UiFramework    
closeCursorMenu(): void Static    
dispatchActionToStore(type: string, payload: any, immediateSync: boolean = false): void Static    
getAccudrawSnapMode(): SnapMode Static    
getActiveIModelId(): string Static    
getActiveSelectionScope(): string Static Returns the stored active selection scope id.  
getAvailableSelectionScopes(): PresentationSelectionScope[] Static Returns the stored list of available selection scopes.  
getColorTheme(): ThemeId Static    
getCursorMenuData(): undefined | CursorMenuData | CursorMenuPayload Static    
getDefaultIModelViewportControlId(): undefined | string Static    
getDefaultViewId(): undefined | string Static    
getDefaultViewState(): undefined | ViewState Static    
getIModelConnection(): undefined | IModelConnection Static    
getIsUiVisible(): boolean Static    
getToolbarOpacity(): number Static UiFramework.getToolbarOpacity() returns a number between 0 and 1 that is the non-hovered opacity for toolbars.  
getUiStateStorage(): UiStateStorage Static The UI Settings Storage is a convenient wrapper around Local Storage to assist in caching state information across user sessions.  
getWidgetOpacity(): number Static    
hideCalculator(): boolean Static Hides the calculator.  
hideComponent(id?: string): boolean Static Hides the Component previously shown with UiFramework.showComponent  
hideKeyinPalette(): boolean Static Hides the Key-in Palette.  
hideMenuButton(id: string): boolean Static Hides a menu button.  
hideToolbar(): boolean Static Hides a toolbar displayed via UiFramework.showToolbar  
initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string): Promise<void> Static Called by the application to initialize the UiFramework.  
initializeStateFromUserSettingsProviders(immediateSync: boolean = false): Promise<void> Static Called by iModelApp to initialize saved UI state from registered UseSettingsProviders  
isMobile(): boolean Static    
openContextMenu(items: CursorMenuItemProps[], location: Readonly<WritableXAndY>, anchorElement?: HTMLElement): boolean Static Show a context menu at a particular location.  
openCursorMenu(menuData: undefined | CursorMenuData | CursorMenuPayload): void Static    
registerUserSettingsProvider(entry: UserSettingsProvider): boolean Static Registers class that will be informed when the UserSettingsStorage location has been set or changed.  
setAccudrawSnapMode(snapMode: SnapMode): void Static    
setActiveIModelId(iModelId: string): void Static    
setActiveSelectionScope(selectionScopeId: string): void Static This method stores the active selection scope to the supplied scope id, and triggers  
setAnimateToolSettings(value: boolean): void Static    
setAutoCollapseUnpinnedPanels(value: boolean): void Static Method used to enable the automatic closing of an unpinned widget panel as soon as the  
setColorTheme(theme: ThemeId): void Static Set the theme value used by the ThemeManager component.  
setDefaultIModelViewportControlId(iModelViewportControlId: string, immediateSync: boolean = false): void Static    
setDefaultViewId(viewId: string, immediateSync: boolean = false): void Static    
setDefaultViewState(viewState: ViewState, immediateSync: boolean = false): void Static    
setHideIsolateEmphasizeActionHandler(handler: undefined | HideIsolateEmphasizeActionHandler): void Static    
setIModelConnection(iModelConnection: undefined | IModelConnection, immediateSync: boolean = false): void Static    
setIsUiVisible(visible: boolean): void Static    
setShowWidgetIcon(value: boolean): void Static    
setToolbarOpacity(opacity: number): void Static UiFramework.setToolbarOpacity() sets the non-hovered opacity to the value specified.  
setUiStateStorage(storage: UiStateStorage, immediateSync: boolean = false): Promise<void> Static    
setUseDragInteraction(useDragInteraction: boolean): void Static    
setUseToolAsToolSettingsLabel(value: boolean): void Static    
setViewOverlayDisplay(display: boolean): void Static Set the variable that controls display of the view overlay.  
setWidgetOpacity(opacity: number): void Static    
showAngleEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static Show an input editor for an angle value at a particular location.  
showCalculator(initialValue: number, resultIcon: string, location: Readonly<WritableXAndY>, onOk: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static Show a calculator at a particular location.  
showComponent(...params: OptionalShowComponentParams): boolean Static Show a React Element at a particular location.  
showDimensionEditor(dimension: "length" | "height", initialValue: number, location: Readonly<WritableXAndY>, onCommit: (value: number) => void, onCancel: () => void, anchorElement?: HTMLElement): boolean Static Show an input editor for a length value at a particular location.  
showKeyinPalette(keyinEntries: KeyinEntry[], htmlElement?: HTMLElement): boolean Static Show the Key-in Palette to display key-in from all registered Tools.  
showMenuButton(id: string, menuItemsProps: CursorMenuItemProps[], location: Readonly<WritableXAndY>, anchorElement?: HTMLElement): boolean Static Show a menu button at a particular location.  
showToolbar(toolbarProps: ToolbarProps, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: (item: any) => void, onCancel: () => void, placement: Placement = "top-end", anchorElement?: HTMLElement): boolean Static Show a Toolbar at a particular location.  
terminate(): void Static Un-registers the UiFramework internationalization service namespace  

Properties

Name Type Description
animateToolSettings Accessor StaticReadOnly boolean Animate Tool Settings on appear  
autoCollapseUnpinnedPanels Accessor StaticReadOnly boolean When true, panels will close as soon as the mouse leave the panel.  
backstage Accessor StaticReadOnly FrameworkBackstage Operation on the backstage component.  
childWindows Accessor StaticReadOnly FrameworkChildWindows Manage access to the child windows.  
content Accessor StaticReadOnly FrameworkContent Manage content presented by the frontstages.  
controls Accessor StaticReadOnly FrameworkControls Manage registered controls  
dialogs Accessor StaticReadOnly FrameworkDialogs Manage displayed dialogs.  
frameworkState Accessor StaticReadOnly undefined | FrameworkState The UiFramework state maintained by Redux  
frameworkStateKey Accessor StaticReadOnly string    
frontstages Accessor StaticReadOnly FrameworkFrontstages Manage access to frontstages and related helper methods.  
hideIsolateEmphasizeActionHandler Accessor StaticReadOnly HideIsolateEmphasizeActionHandler    
initialized Accessor StaticReadOnly boolean Determines if UiFramework has been initialized  
keyboardShortcuts Accessor StaticReadOnly FrameworkKeyboardShortcuts Manages global keyboard shortcuts  
localizationNamespace Accessor StaticReadOnly string The internationalization service namespace.  
onUiVisibilityChanged StaticReadonly UiVisibilityChangedEvent Get Show Ui event.  
settingsManager Accessor StaticReadOnly SettingsManager Property that returns the SettingManager used by AppUI-based applications.  
showWidgetIcon Accessor StaticReadOnly boolean    
store Accessor StaticReadOnly Store<any, AnyAction> The Redux store  
toolSettings Accessor StaticReadOnly FrameworkToolSettings Manage access and behavior of the tool settings.  
useDefaultPopoutUrl Static boolean    
useDragInteraction Accessor StaticReadOnly boolean    
useToolAsToolSettingsLabel Accessor StaticReadOnly boolean Use Tool Name As Tool Settings Widget Tab Label  
viewOverlayDisplay Accessor StaticReadOnly boolean Returns the variable controlling whether the overlay is displayed in a Viewport  
visibility Accessor StaticReadOnly FrameworkVisibility Manages UI visibility (Show/Hide)  

Defined in

Last Updated: 21 March, 2024