WidgetControl Class

The base class for Widget controls.

Extends

Extended by

Methods

Name Description
constructor(info: ConfigurableCreateInfo, options: any): WidgetControl    
getType(): ConfigurableUiControlType Gets the type of ConfigurableUiControl, which is 'Widget' in this case  
onWidgetStateChanged(): void Called when widget state changes.  
restoreTransientState(): boolean Overwrite to restore transient DOM state.  
saveTransientState(): void Overwrite to save transient DOM state (i.e.  
setWidgetState(state: WidgetState): void Sets the WidgetState for this control  

Inherited methods

Name Inherited from Description
onFrontstageDeactivated(): void ConfigurableUiControl Called when Frontstage is deactivated.
onFrontstageReady(): void ConfigurableUiControl Called when Frontstage is ready.
onInitialize(): void ConfigurableUiControl Called to initialize the ConfigurableUiControl.

Properties

Name Type Description
reactNode Accessor ReactNode The ReactNode associated with this control  
widgetDef Accessor WidgetDef The WidgetDef associated with this control  

Inherited properties

Name Type Inherited from Description
_appDataOptions Protected any ConfigurableUiControl  
applicationData Accessor ReadOnly any ConfigurableUiControl allow options set via appData to be seen by API calls
classId Accessor ReadOnly string ConfigurableUiControl Gets the class Id of configurable element
controlId Accessor ReadOnly string ConfigurableUiControl Returns the ID of this ConfigurableUiControl.
isReady Accessor ReadOnly Promise<void> ConfigurableUiControl Returns a promise that resolves when the control is ready for usage.
name Accessor ReadOnly string ConfigurableUiControl Get internal name of configurable element. If no name is defined in configuration
then the name will match the UniqueId.

Defined in

Last Updated: 05 April, 2024