WidgetManager Class

Widget Manager class.

Methods

Name Description
constructor(): WidgetManager    
addWidgetDef(widgetDef: WidgetDef, stageId: undefined | string, stageUsage: undefined | string, location: StagePanelLocation, section?: StagePanelSection): boolean Adds a WidgetDef for use in a Frontstage.  
getWidgetDefs(stageId: string, stageUsage: string, location: StagePanelLocation, section?: StagePanelSection): undefined | Gets WidgetDefs for a Frontstage location.  
removeWidgetDef(widgetId: string): boolean Removes a WidgetDef.  

Defined in

Last Updated: 05 April, 2024