DataController Interface

DataControllers can be implemented per typename to validate and commit values.

Implemented by

Methods

Name Description
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult>    
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult>    

Defined in

Last Updated: 21 March, 2024