PropertyRecord Class

PropertyRecord contains instance information about a Property, including a value that can be edited using a PropertyEditor and converted using a TypeConverter.

Methods

Name Description
constructor(value: PropertyValue, property: PropertyDescription): PropertyRecord Constructs a PropertyRecord instance  
copyWithNewValue(newValue: PropertyValue, newDescription?: PropertyDescription): PropertyRecord Creates a copy of this PropertyRecord with a new value and optionally a new PropertyDescription  
getChildrenRecords(): PropertyRecord[] Gets this property record value children records  
fromString(value: string, descriptionOrName?: string | PropertyDescription): PropertyRecord Static Creates a PropertyRecord based on a value string and an optional property description or name  

Properties

Name Type Description
autoExpand undefined | boolean Indicates if the property should be automatically expanded  
description undefined | string Description for the property  
extendedData undefined | { T } Map containing any additional data  
isDisabled undefined | boolean Indicates if the property is disabled  
isMerged undefined | boolean Indicates if the property record represents merged properties  
isReadonly undefined | boolean Indicates if the property is read-only  
undefined | LinkElementsInfo Properties for link logic  
property Readonly PropertyDescription The property description containing metadata for the property  
value Readonly PropertyValue Value for the property  

Defined in

Last Updated: 16 April, 2024