TextAnnotation3d Class

3D Text Annotation

Extends

Methods

Name Description
constructor(props: GeometricElement3dProps, iModel: IModelDb): TextAnnotation3d Protected    

Inherited methods

Name Inherited from Description
calculateRange3d(): Range3d GraphicalElement3d  
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected GraphicalElement3d Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected GraphicalElement3d Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void GraphicalElement3d Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void GraphicalElement3d Call a function for each property of this Entity.
GraphicalElement3d Get the class metadata for this element.
getDisplayLabel(): string GraphicalElement3d Get a display label for this Element.
getJsonProperty(nameSpace: string): any GraphicalElement3d Get a JSON property of this element, by namespace
getPlacementTransform(): Transform GraphicalElement3d Get the Transform from the Placement of this GeometricElement
getPredecessorIds(): Id64Set GraphicalElement3d Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet GraphicalElement3d Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] GraphicalElement3d Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any GraphicalElement3d Get a set of JSON user properties by namespace
insert(): string GraphicalElement3d Insert this Element into the iModel.
is2d(): this is GeometricElement2d GraphicalElement3d Type guard for instanceof GeometricElement2d
is3d(): this is GeometricElement3d GraphicalElement3d Type guard for instanceof GeometricElement3d
removeUserProperties(nameSpace: string): void GraphicalElement3d Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void GraphicalElement3d  
setUserProperties(nameSpace: string, value: any): void GraphicalElement3d Change a set of user JSON properties of this Element by namespace.
toJSON(): GeometricElement3dProps GraphicalElement3d Obtain the JSON representation of this Entity.
update(): void GraphicalElement3d Update this Element in the iModel.
is(otherClass: undefined): boolean Static GraphicalElement3d return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic GraphicalElement3d Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic GraphicalElement3d Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic GraphicalElement3d Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic GraphicalElement3d Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic GraphicalElement3d Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic GraphicalElement3d Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic GraphicalElement3d Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic GraphicalElement3d Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic GraphicalElement3d Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic GraphicalElement3d Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic GraphicalElement3d Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic GraphicalElement3d Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic GraphicalElement3d Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic GraphicalElement3d Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic GraphicalElement3d Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic GraphicalElement3d Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic GraphicalElement3d Called after an Element was updated.

Inherited properties

Name Type Inherited from Description
category string GraphicalElement3d The Id of the Category for this GeometricElement.
classFullName Accessor ReadOnly string GraphicalElement3d Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string GraphicalElement3d Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string GraphicalElement3d The name of the BIS class associated with this class.
code Code GraphicalElement3d The Code for this element
elementGeometryBuilderParams undefined | ElementGeometryBuilderParams GraphicalElement3d How to build the element's GeometryStream.
federationGuid undefined | string GraphicalElement3d A FederationGuid assigned to this element by some other federated database
geom undefined | GeometryStreamProps GraphicalElement3d The GeometryStream for this GeometricElement.
id string GraphicalElement3d The Id of this Entity.
iModel IModelDb GraphicalElement3d The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" GraphicalElement3d An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly { T } GraphicalElement3d Optional json properties of this element.
model Readonly string GraphicalElement3d The ModelId of the Model containing this element
parent undefined | RelatedElement GraphicalElement3d The parent element, if present, of this element.
placement Placement3d GraphicalElement3d  
requiredReferenceKeys StaticReadonly undefined GraphicalElement3d  
schema Static undefined GraphicalElement3d The Schema that defines this class.
schemaName Accessor ReadOnly string GraphicalElement3d The name of the BIS Schema that defines this class
typeDefinition undefined | TypeDefinition GraphicalElement3d  
userLabel undefined | string GraphicalElement3d A user-assigned label for this element.

Defined in

Last Updated: 16 April, 2024