upgradeSchemas MethodStatic

Upgrades the schemas in the iModel based on the current version of the software. Follows a sequence of operations -

  • Acquires a schema lock to prevent other users from making any other changes while upgrade is happening
  • Updates the local briefcase with the schema changes.
  • Pushes the resulting changeset(s) to iModelHub. Note that the upgrade requires that the local briefcase be closed, and may result in one or two change sets depending on whether both profile and domain schemas need to get upgraded.

upgradeSchemas(briefcase: OpenBriefcaseArgs): Promise<void>

@see ($docs/learning/backend/IModelDb.md#upgrading-schemas-in-an-imodel)

Parameter Type Description
briefcase OpenBriefcaseArgs  

Returns - Promise<void>

Defined in

Last Updated: 16 April, 2024