performCheckpoint Method

Save all changes and perform a checkpoint on this IModelDb. This ensures that all changes to the database since it was opened are saved to its file and the WAL file is truncated.

performCheckpoint(): void

@note Checkpoint automatically happens when IModelDbs are closed. However, the checkpoint operation itself can take some time. It may be useful to call this method prior to closing so that the checkpoint "penalty" is paid earlier.

@note Another use for this function is to permit the file to be copied while it is open for write. iModel files should rarely be copied, and even less so while they're opened. But this scenario is sometimes encountered for tests.

Returns - void

Defined in

Last Updated: 16 April, 2024