prepareStatement Method

Deprecated  in 4.11. Use IModelDb.createQueryReader or ECDb.createQueryReader to query.

IModelDb.createQueryReader is an asynchronous API. If you encounter a use case that cannot be converted to async, please report an issue at https://github.com/iTwin/itwinjs-core/issues. Mean while use IModelDb.withPreparedStatement for synchronous API calls where conversion to async is not possible.

Prepare an ECSQL statement.

prepareStatement(sql: string, logErrors: booleantrue): ECSqlStatement

@throws IModelError if there is a problem preparing the statement.

Parameter Type Description
sql string The ECSQL statement to prepare
logErrors boolean Determines if error will be logged if statement fail to prepare

Returns - ECSqlStatement

Defined in

Last Updated: 29 April, 2025