GeometricElement3dHasTypeDefinition Class

Relates a GeometricElement3d to its TypeDefinitionElement

Extends

Extended by

Methods

Name Description
constructor(id: string, relClassName: string = GeometricElement3dHasTypeDefinition.classFullName): GeometricElement3dHasTypeDefinition    

Inherited methods

Name Inherited from Description
toJSON(): RelatedElementProps TypeDefinition  
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static TypeDefinition  
idFromJson(json: any): string Static TypeDefinition Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format.

Properties

Name Type Description
classFullName Static string    

Inherited properties

Name Type Inherited from Description
id Readonly string TypeDefinition The Id of the element to which this element is related.
none StaticReadonly RelatedElement TypeDefinition Used to null out an existing navigation relationship.
relClassName Readonly undefined | string TypeDefinition The full className of the relationship class.

Defined in

Last Updated: 15 March, 2024