GraphicalElement2dIsOfType Class

Relates a GraphicalElement2d to its GraphicalType2d

Extends

Methods

Name Description
constructor(id: string, relClassName: string = GraphicalElement2dIsOfType.classFullName): GraphicalElement2dIsOfType    

Inherited methods

Name Inherited from Description
toJSON(): RelatedElementProps GeometricElement2dHasTypeDefinition  
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static GeometricElement2dHasTypeDefinition  
idFromJson(json: any): string Static GeometricElement2dHasTypeDefinition Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format.

Properties

Name Type Description
classFullName Static string    

Inherited properties

Name Type Inherited from Description
id Readonly string GeometricElement2dHasTypeDefinition The Id of the element to which this element is related.
none StaticReadonly RelatedElement GeometricElement2dHasTypeDefinition Used to null out an existing navigation relationship.
relClassName Readonly undefined | string GeometricElement2dHasTypeDefinition The full className of the relationship class.

Defined in

Last Updated: 16 April, 2024