WebAppRpcLoggingBackend Class

Extends

  • WebAppRpcLogging

Methods

Name Description
constructor(): WebAppRpcLoggingBackend    
getHostname(): string Protected    
logProtocolEvent(event: RpcProtocolEvent, object: RpcInvocation): Promise<void> Protected    

Inherited methods

Name Inherited from Description
buildOperationDescriptor(operation: RpcOperation | SerializedRpcOperation): string Protected WebAppRpcLogging  
findPathIds(path: string): { iModelId: string, iTwinId: string } Protected WebAppRpcLogging  
getRpcInterfaceName(g: string | RpcInterfaceDefinition<RpcInterface>): string Protected WebAppRpcLogging  
logRequest(loggerCategory: string, message: string, object: WebAppRpcRequest | SerializedRpcRequest): void Protected WebAppRpcLogging  
logResponse(loggerCategory: string, message: string, object: WebAppRpcRequest | SerializedRpcRequest, status: number, elapsed: number): void Protected WebAppRpcLogging  
initializeBackend(instance: WebAppRpcLogging): void Static WebAppRpcLogging  
initializeFrontend(instance: WebAppRpcLogging): void Static WebAppRpcLogging  
logProtocolEvent(event: RpcProtocolEvent, object: RpcInvocation | RpcRequest<any>): Promise<void> Static WebAppRpcLogging  

Defined in

Last Updated: 15 March, 2024