ClassRegistry Class

The mapping between a BIS class name (in the form "schema:class") and its JavaScript constructor function

Methods

Name Description
constructor(): ClassRegistry    
findRegisteredClass(classFullName: string): undefined | Static Find a registered class by classFullName.  
getClass(classFullName: string, iModel: IModelDb): undefined Static Get the Entity class for the specified Entity className.  
registerModule(moduleObj: any, schema: undefined): void Static Register all of the classes found in the given module that derive from Entity.  

Defined in

Last Updated: 16 April, 2024