Uint8ArrayBuilder Class

A TypedArrayBuilder for producing a Uint8Array.

Extends

Methods

Name Description
constructor(options?: TypedArrayBuilderOptions): Uint8ArrayBuilder See TypedArrayBuilder constructor.  

Inherited methods

Name Inherited from Description
append(values: Uint8Array): void TypedArrayBuilder<Uint8Array> Append an array of values, resizing (at most once) if necessary.
at(index: number): number TypedArrayBuilder<Uint8Array> Like TypedArray.at,
ensureCapacity(newCapacity: number): number TypedArrayBuilder<Uint8Array> Ensure that TypedArrayBuilder.capacity is at least equal to newCapacity.
push(value: number): void TypedArrayBuilder<Uint8Array> Append the specified value, resizing if necessary.
toTypedArray(includeUnusedCapacity: boolean = false): Uint8Array TypedArrayBuilder<Uint8Array> Obtain the finished array.

Inherited properties

Name Type Inherited from Description
_constructor Protected Constructor<Uint8Array> TypedArrayBuilder<Uint8Array> The constructor for the specific type of array being populated.
_data Protected Uint8Array TypedArrayBuilder<Uint8Array> The underlying typed array, to be reallocated and copied when its capacity is exceeded.
_length Protected number TypedArrayBuilder<Uint8Array> The number of elements added to the array so far.
capacity Accessor ReadOnly number TypedArrayBuilder<Uint8Array> The number of elements that can fit into the memory currently allocated for the array.
growthFactor Readonly number TypedArrayBuilder<Uint8Array> Multiplier applied to required capacity by TypedArrayBuilder.ensureCapacity.
length Accessor ReadOnly number TypedArrayBuilder<Uint8Array> The number of elements currently in the array.

Defined in

Last Updated: 15 March, 2024