Id64.Uint32Map<T> Class

A specialized replacement for Map<Id64String, T> optimized for performance-critical code.

@see Id64.Uint32Set for implementation details.

Methods

Name Description
constructor<T>(): Id64.Uint32Map<T>    
clear(): void Remove all entries from the map.  
forEach(func: (lo: number, hi: number, value: T) => void): void Execute a function against each entry in this map.  
get(low: number, high: number): undefined | T Get an entry from the map by Id components.  
getById(id: string): undefined | T Find an entry in the map by Id.  
set(low: number, high: number, value: T): void Set an entry in the map by Id components.  
setById(id: string, value: T): void Set an entry in the map by Id.  

Properties

Name Type Description
_map ProtectedReadonly Map<number, Map<number, T>>    
isEmpty Accessor ReadOnly boolean Returns true if the map contains no entries.  
size Accessor ReadOnly number Returns the number of entries in the map.  

Defined in

Last Updated: 16 April, 2024