Atmosphere.Settings Class

Describes the properties with which the atmospheric scattering effect should be drawn. Theses properties correspond to a physics-based approximation of atmospheric scattering phenomenons.

Methods

Name Description
equals(other: Atmosphere.Settings): boolean    
toJSON(display?: boolean): Atmosphere.Props    
fromJSON(json?: Atmosphere.Props): Atmosphere.Settings Static    

Properties

Name Type Description
defaults StaticReadonly Atmosphere.Settings    
exposure Readonly number If defined, this value is used to simulate the aperture of a camera.  
highQuality StaticReadonly Atmosphere.Settings    
numSunRaySamples Readonly number If defined, corresponds to the number of atmospheric density samples uses to compute the amount of light scattered along each sun ray.  
numViewRaySamples Readonly number If defined, corresponds to the number of atmospheric density samples used to compute the amount of light scattered along each view ray.  

Defined in

Last Updated: 16 April, 2024