AffineTransform Class

The equations are: X1 = a1X + a2Y + TranslationX Y1 = b1X + b2Y + translationY An affine representing no transformation will have: a1 = 1.0, a2 = 0.0, b1 = 0.0, b2 = 1.0.

Implements

Methods

Name Description
constructor(data?: AffineTransformProps): AffineTransform    
equals(other: AffineTransform): boolean Compares two Affine Transforms.  
toJSON(): AffineTransformProps Creates a JSON from the Affine Transform definition  
fromJSON(data: AffineTransformProps): AffineTransform Static Creates an Affine Transform from JSON representation.  

Properties

Name Type Description
a1 Readonly number A1 value as defined in global comment.  
a2 Readonly number A2 value as defined in global comment.  
b1 Readonly number B1 value as defined in global comment.  
b2 Readonly number B2 value as defined in global comment.  
translationX Readonly number The X post translation  
translationY Readonly number The Y post-translation  

Defined in

Last Updated: 15 March, 2024