FrustumPlanes Namespace

Enumeration

Name Description
FrustumPlanes.Containment Describes the degree to which an object is contained within the planes of a Frustum.

Defined in

FrustumPlanes Class

Represents a the planes of a Frustum for testing containment and intersection. A valid frustum produces six planes. A degenerate frustum produces zero planes.

Methods

Name Description
computeContainment(points: Point3d[], sphere?: BoundingSphere, tolerance: number = 1.0e-8): FrustumPlanes.Containment Compute the degree to which a set of points is contained within these frustum planes.  
computeFrustumContainment(box: Frustum, sphere?: BoundingSphere): FrustumPlanes.Containment Compute to what degree a Frustum is contained with these frustum planes.  
containsPoint(point: Point3d, tolerance: number = 1.0e-8): boolean Determines whether a point is contained within these frustum planes.  
init(frustum: Frustum): boolean Recompute the planes from the specified frustum.  
intersectsFrustum(box: Frustum, sphere?: BoundingSphere): boolean Determines whether a Frustum intersects with or is fully contained within these frustum planes.  
intersectsRay(origin: Point3d, direction: Vector3d): boolean Computes whether a ray intersects these clipping planes.  
createEmpty(): FrustumPlanes Static Create an empty set of frustum planes.  
fromFrustum(frustum: Frustum): FrustumPlanes Static Compute the six planes of the specified frustum.  

Properties

Name Type Description
isValid Accessor ReadOnly boolean Returns true if FrustumPlanes.planes consists of six planes.  
planes Accessor ReadOnly ClipPlane[] Obtain the list of planes defining the frustum.  

Defined in

Last Updated: 15 March, 2024