GeometrySummaryOptions Interface

Describes what information to include in a GeometrySummaryRequestProps.

Properties

Name Type Description
geometryVerbosity undefined | GeometrySummaryVerbosity The level of detail with which to summarize each geometric primitive.  
includePartReferences "2d" | "3d" If defined, for each geometry part, output a list of all geometric elements that reference that part in their geometry streams.  
includePlacement undefined | boolean If true, include placement information for geometric elements.  
verboseSymbology undefined | boolean If true, include detailed description of each symbology change (e.g., output material Id, line/fill color, etc).  

Defined in

Last Updated: 16 April, 2024