GridFileDefinition Class

Grid file definition containing name of the file, the format and the direction it should be applied

Implements

Methods

Name Description
constructor(data?: GridFileDefinitionProps): GridFileDefinition    
equals(other: GridFileDefinition): boolean Compares two grid file definition.  
toJSON(): GridFileDefinitionProps Creates a JSON from the Grid File Definition  
fromJSON(data: GridFileDefinitionProps): GridFileDefinition Static Creates a Grid File Definition from JSON representation.  

Properties

Name Type Description
direction Readonly GridFileDirection The grid file application direction  
fileName Readonly string Name of the grid shift file.  
format Readonly GridFileFormat The grid file format  

Defined in

Last Updated: 15 March, 2024