HorizontalCRSExtent Class

The extent in latitude, longitude bounds where a horizontal CRS is applicable

Implements

Methods

Name Description
constructor(data?: HorizontalCRSExtentProps): HorizontalCRSExtent    
equals(other: HorizontalCRSExtent): boolean Compares two Extents.  
toJSON(): HorizontalCRSExtentProps Creates a JSON from the Extent definition  
fromJSON(data: HorizontalCRSExtentProps): HorizontalCRSExtent Static Creates an extent object from JSON representation.  

Properties

Name Type Description
northEast Readonly Carto2DDegrees The North East point in latitude in longitude in degrees for the user-defined extent of the CRS.  
southWest Readonly Carto2DDegrees The latitude minimum and maximum for the user-defined extent of the CRS  

Defined in

Last Updated: 15 March, 2024