VerticalCRS Class

Vertical Coordinate reference System implementation. The VerticalCRS contains currently a single identifier property of string type. Although we currently only support five distinct key values "GEOID", "ELLIPSOID", "NAVD88", "NGVD29" and "LOCAL_ELLIPSOID" we expect to support a broader set in the future including, eventually, user defined vertical CRS which will require additional parameters to be added.

Implements

Methods

Name Description
constructor(data?: VerticalCRSProps): VerticalCRS    
equals(other: VerticalCRS): boolean Compares two vertical CRS.  
toJSON(): VerticalCRSProps Creates a JSON from the Vertical CRS definition  
fromJSON(data: VerticalCRSProps): VerticalCRS Static Creates a Vertical CRS from JSON representation.  

Properties

Name Type Description
id Readonly "GEOID" | "ELLIPSOID" | "NGVD29" | "NAVD88" | "LOCAL_ELLIPSOID" Vertical CRS Key name.  

Defined in

Last Updated: 16 April, 2024