DbQueryError Class

Extends

Methods

Name Description
constructor(response: any, request?: any, rc?: DbResult): DbQueryError    
throwIfError(response: any, request?: any): void Static    

Inherited methods

Name Inherited from Description
_initName(): string Protected BentleyError This function returns the name of each error status.
BentleyError get the meta data associated with this BentleyError, if any.
getErrorMessage(error: unknown): string Static BentleyError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
BentleyError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static BentleyError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static BentleyError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
BentleyError get the metadata object associated with an ExceptionMetaData, if any.

Properties

Name Type Description
request Readonly undefined | any    
response Readonly any    

Inherited properties

Name Type Inherited from Description
errorNumber number BentleyError  
boolean BentleyError Returns true if this BentleyError includes (optional) metadata.

Defined in

Last Updated: 15 March, 2024