ServerTimeoutError Class

Extends

Methods

Name Description
constructor(message: string): ServerTimeoutError    

Inherited methods

Name Inherited from Description
_initName(): string Protected ServerError This function returns the name of each error status.
ServerError get the meta data associated with this BentleyError, if any.
getErrorMessage(error: unknown): string Static ServerError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
ServerError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static ServerError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static ServerError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
ServerError get the metadata object associated with an ExceptionMetaData, if any.

Inherited properties

Name Type Inherited from Description
errorNumber number ServerError  
boolean ServerError Returns true if this BentleyError includes (optional) metadata.

Defined in

Last Updated: 16 April, 2024